package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\p{N}\p{L}\-+\.]{1,500}\.[\p{N}\p{L}][\p{L}-]*[\p{N}\p{L}]+$`)
var str = `google.com
masełkowski.pl
maselkowski.pl
m.maselkowski.pl
www.masełkowski.pl.com
xn--masekowski-d0b.pl
中国互联网络信息中心.中国
masełkowski.pl.
masełk..owski.pl
中国互联网络信息中心.xn--masekowski-d0b
api.aaaaaaaaaaaaaaaaaa34.23ab34bcde.343434343434343434.a1b2c3d4.urab.org
xxx
ayx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}