package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)
(?<string>"[^"]+")
)
\(
(?&string)?
(?:,(?&string)?)*
\)`)
var str = `("My","Cool","Array")
("My","Cool","Array",)
(,,"My","Cool",,"Array",,,)
("My""Cool""Array")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}