using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"test(?!.*<\/a)";
string input = @"mmmmm mmmmmmm mmmmmmm mmmmmm mmmmmmm mmmmm mmmmm mmmmmmmmmmmmm
mmmmm <a href=""ttt"">test</a> mmmm mmmmm test test mm mmmmmmm
mmmmm <a href=""ttt""> test </a> mmmm mmmmm test test mm mmmmmmm
mmmmm <a href=""ttt"">mmm test</a> mmmm mmmmm test test mmmmmmmm
mmmmm <a href=""ttt"">test mmm </a> mmmm mmmmm test test mmmmmmm
mmmmm <a href=""ttt"" > mmm test mmm </a> mmmm mm test test mmmm
mmmmm mmmmmmm mmmmmmm mmmmmm mmmmmmm mmmmm mmmmm mmmmmmmmmmmmm";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}