#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\s{3})([a-zA_Z0-9]*)(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})"
Local $sString = " 1 2 3 4 5 6 7 8 [9] " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[REPLACEALL](\s{3})([a-zA_Z0-9]*)(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})[WITH]$3$4$2$6$3$5$1"
Local $sSubst = "$3$4$2$6$3$5$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)