using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s{3})([a-zA_Z0-9]*)(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})";
string substitution = @"$3$4$2$6$3$5$1";
string input = @" 1 2 3 4 5 6 7 8 [9]
[REPLACEALL](\s{3})([a-zA_Z0-9]*)(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})[WITH]$3$4$2$6$3$5$1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}