package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s{3})([a-zA_Z0-9]*)(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})`)
var str = ` 1 2 3 4 5 6 7 8 [9]
[REPLACEALL](\s{3})([a-zA_Z0-9]*)(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})[WITH]$3$4$2$6$3$5$1`
var substitution = "$3$4$2$6$3$5$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}