use strict;
my $str = ' 1 2 3 4 5 6 7 8 [9]
[REPLACEALL](\\s{3})([a-zA_Z0-9]*)(\\s{2})(\\[)([a-zA_Z0-9]*)(\\])(\\s{2})[WITH]$3$4$2$6$3$5$1';
my $regex = qr/(\s{3})([a-zA_Z0-9]*)(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})/p;
my $subst = '$3$4$2$6$3$5$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";