// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\s{3})([a-zA_Z0-9]*)(\s{2})(\[)([a-zA_Z0-9]*)(\])(\s{2})").unwrap();
let string = " 1 2 3 4 5 6 7 8 [9]
[REPLACEALL](\\s{3})([a-zA_Z0-9]*)(\\s{2})(\\[)([a-zA_Z0-9]*)(\\])(\\s{2})[WITH]$3$4$2$6$3$5$1";
let substitution = "$3$4$2$6$3$5$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}