#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^\s*[\w\-\+_]+(\.[\w\-\+_]+)*\@[\w\-\+_]+\.[\w\-\+_]+(\.[\w\-\+_]+)*\s*$"
Local $sString = "g.g@asd.jfas.com.ua"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)