// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<p>(<i>|<strong>)*<img\sclass="mceItem_breakpoint".*>(<\/i>|<\/strong>)?<\/p>"#).unwrap();
let string = "<p><img class=\"mceItem_breakpoint\" src=\"></p>
<h4>Platzteller</h4>
<p>Der Platzteller, auf dem Vorspeisen- und Suppenteller rechts daneben</p>
<p><i><img class=\"mceItem_breakpoint\" src=\"\" /></i></p>
<p><strong><img class=\"mceItem_breakpoint\" src=\"\"></strong></p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}