package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(UPDATE|INSERT\s).*?(?:\;)\n`)
var str = `INSERT ;
INSERT 1233;`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}