re = /([\d\s\.,:\/]+)/
str = '335.31, 312.52
Dave1.532
Path: "./1243/453 /48.1"
543, 546
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end