using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\b(?:src=|background\-image:).*$";
string input = @"src=""./seg3125_p2.github.io/images/img-1.jpg""
src='./images/img-1.jpg'
src= ""./seg3125_p2.github.io/images/img-1.jpg""
src= './images/img-1.jpg'
background-image: url(""https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg"");
background-image: url('https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg');
background-image:url(""https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg"");
background-image:url('https://diegobajetti.github.io/seg3125_p2.github.io/images/img-1.jpg');
<video src={""./seg3125_p2.github.io/videos/video-1.mp4""}/>
<video src={'./seg3125_p2.github.io/videos/video-1.mp4'}/>
<video
src={""./seg3125_p2.github.io/videos/video-1.mp4""}
autoPlay=""autoPlay""
loop=""loop""
muted=""muted""
playsInline=""playsInline""
/>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}