using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Level (300|[0-2]?\d?\d) ([^<]*)";
string input = @"<br />Level 163 Operative </div> <div class=""sectionBar"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}