package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<p><\/p>)+`)
var str = `<p></p>fsadfsafsa
<p></p>
<p>adfsafa</p>
<p>fdsafsafa</p>
<p></p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}