$re = '/^.*(?=cart total).*(?=(greater|less)).*(?=\$?([0-9.]+))/m';
$str = 'cart total is greater than $5.00
cart total is less than $5.00
cart total is greater than 5.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);