$re = '/\.\w{3,4}($|\?)/mi';
$str = 'online.jsp
file.jsp?callback';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);