$re = '/^\d\.\d{2}$/m';
$str = '1.23
0.12
21.21
1.2
3.1111
s.34
0dsj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);