using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"interface(\s[\w\d\/.]+)(.*)?";
string input = @"interface eth1/10.404 p2p
interface ae0.100 p2p
interface pool0 multibind lastresort
interface loop0 loopback
interface ae0.100
interface loop0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}