re = /interface(\s[\w\d\/.]+)(.*)?/m
str = 'interface eth1/10.404 p2p
interface ae0.100 p2p
interface pool0 multibind lastresort
interface loop0 loopback
interface ae0.100
interface loop0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end