package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*{(\w+)}\s*=`)
var str = ` {blah_blah} = 2015-03-02;`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}