import Foundation
let pattern = #"^\s*{(\w+)}\s*="#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" {blah_blah} = 2015-03-02;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}