using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"test_function\((?!\w+\('[^'\\]*(?:\\.[^'\\]*)*'(?:,(?:true|false))*\)\)|'[^'\\]*(?:\\.[^'\\]*)*'\))";
string input = @"test_function('something',true);
test_function('something',false);
test_function('something',true,true);
test_function(another_function('anotherthing',true),true);
don't want to find this:
test_function('something');
test_function('something').another_function(something,true);
test_function(another_function('anotherthing',true));";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}