#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([a-zA-Z]{3}) (\d 2}), (\d{4})"
Local $sString = "Nov 6 2022"
Local $sSubst = "$2-$1-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)