using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z]{3}) (\d 2}), (\d{4})";
string substitution = @"$2-$1-$3";
string input = @"Nov 6 2022";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}