$re = '/([a-zA-Z]{3}) (\d 2}), (\d{4})/';
$str = 'Nov 6 2022';
$subst = "$2-$1-$3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;