using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d+\.?\d*) ([a-zA-Z]) \*)(.*?)(((\d+\.?\d*) \3 \*))";
string substitution = @"$3 $2 $6 + * $4";
string input = @"2 x * 3 y * + 3 x * + 4 y * + 3 x * +";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}