use strict;
my $str = '2 x * 3 y * + 3 x * + 4 y * + 3 x * +';
my $regex = qr/((\d+\.?\d*) ([a-zA-Z]) \*)(.*?)(((\d+\.?\d*) \3 \*))/p;
my $subst = '$3 $2 $6 + * $4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";