#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z A-Z]+\d{0,5} ?[a-zA-Z]?"
Local $sString = "Oslo gate 20" & @CRLF & _
"Oslo gate 39a" & @CRLF & _
"Oslo gate 39 a" & @CRLF & _
"Oslo Gate" & @CRLF & _
"Oslo" & @CRLF & _
"30" & @CRLF & _
"Oslo gate49a" & @CRLF & _
" Oslo gate 39a" & @CRLF & _
"Oslo gate 34a, leil. H0205" & @CRLF & _
"leil. H0205, Oslo gate 34a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")