using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z A-Z]+\d{0,5} ?[a-zA-Z]?";
string input = @"Oslo gate 20
Oslo gate 39a
Oslo gate 39 a
Oslo Gate
Oslo
30
Oslo gate49a
Oslo gate 39a
Oslo gate 34a, leil. H0205
leil. H0205, Oslo gate 34a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}