import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z A-Z]+\\d{0,5} ?[a-zA-Z]?";
final String string = "Oslo gate 20\n"
+ "Oslo gate 39a\n"
+ "Oslo gate 39 a\n"
+ "Oslo Gate\n"
+ "Oslo\n"
+ "30\n"
+ "Oslo gate49a\n"
+ " Oslo gate 39a\n"
+ "Oslo gate 34a, leil. H0205\n"
+ "leil. H0205, Oslo gate 34a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}