use strict;
my $str = 'Oslo gate 20
Oslo gate 39a
Oslo gate 39 a
Oslo Gate
Oslo
30
Oslo gate49a
Oslo gate 39a
Oslo gate 34a, leil. H0205
leil. H0205, Oslo gate 34a';
my $regex = qr/^[a-z A-Z]+\d{0,5} ?[a-zA-Z]?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}