package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Ваш заказ доступен по адресу:(?:\s++(?:[а-яА-Я\w\d,!]++|\.)*?){1,3}\s*+\.\sЗабирайте скорее!$`)
var str = `Ва ш заказ доступен по адресу: dfdfdf dfdfdfdfdfdfdfdfdfdfd sfdnjв. Забирайте скорее!`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}