import Foundation
let pattern = #"((?=\b(?:[a-df-z0-9_]*e[a-df-z0-9_]*){2}\b)(?=\b(?:[b-z0-9_]*a[b-z0-9_]*){1,3}\b).+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
a eea
oe
eeae
alargedonkey
thebiggestmushroom
cheese
acheese
cheesy
cheesybread
cheesyapp
alphabetchocolate
alphabetonaplate
ayellowalphabetonaplate
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)