import re
regex = re.compile(r"\*e UserInterface Extensions Event (Pressed|Released|Clicked|Changed) Signal: (\"(.*)\")")
test_str = ("*e UserInterface Extensions Event Changed Signal: \"togglebutton:on\"\n"
"*e UserInterface Extensions Event Changed Signal: \"togglebutton:off\"\n"
"*e UserInterface Extensions Event Pressed Signal: \"slider\"\n"
"*e UserInterface Extensions Event Changed Signal: \"slider:32\"\n"
"*e UserInterface Extensions Event Changed Signal: \"slider:68\"\n"
"*e UserInterface Extensions Event Released Signal: \"slider:68\"\n"
"*e UserInterface Extensions Event Pressed Signal: \"spinner:decrement\"\n"
"*e UserInterface Extensions Event Released Signal: \"spinner:decrement\"\n"
"*e UserInterface Extensions Event Clicked Signal: \"spinner:decrement\"\n"
"*e UserInterface Extensions Event Pressed Signal: \"button\"\n"
"*e UserInterface Extensions Event Released Signal: \"button\"\n"
"*e UserInterface Extensions Event Clicked Signal: \"button\"\n"
"*e UserInterface Extensions Event Pressed Signal: \"symbol\"\n"
"*e UserInterface Extensions Event Released Signal: \"symbol\"\n"
"*e UserInterface Extensions Event Clicked Signal: \"symbol\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")