re = /(?=(\b\w{4,}\b)(?:.*\b\1\b){2})(?!(\b\w{4,}\b)(?:.*\b\1\b){3})/i
str = 'hello how are you today hello hello hello
'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result