use strict;
my $str = '/pp/dc/dc1/h1
...
/pp/dc/dc1/h100
or
/pp/dc/dc2/h1
...
/pp/dc/dc2/h100
or
/pp/dc/dc3/h1
...
/pp/dc/dc3/h100
/pp/dc/dc3/h101
/pp/dc/dc3/h155
/pp/dc/dc2/h10/pro
';
my $regex = qr/^/pp/dc/dc[123]/h([1-9]{1,2}|100)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}