use strict;
my $str = 'of John at /roger/adam1/sam dfd';
my $regex = qr/(of\s*)[a-zA-Z\d]+(\s*at\s*).*(?=\s)/mp;
my $subst = '$1$value$2$XPath';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";