$re = '/(?:E\d)([\w\d_]+)(?:_LLC)/';
$str = '0x010102_default_prg_L2_E2_LDep1_LLC
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);