const regex = /^(\+|-|)(\d+\.|\.\d+|\d+|\d+\.\d+)((e+|e-|e)\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+|-|)(\\d+\\.|\\.\\d+|\\d+|\\d+\\.\\d+)((e+|e-|e)\\d+)?$', 'gm')
const str = `1+1
1f5`;
const subst = `$`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);