$re = '/^(\+|-|)(\d+\.|\.\d+|\d+|\d+\.\d+)((e+|e-|e)\d+)?$/m';
$str = '1+1
1f5';
$subst = "$";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;