# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/data:\s*{\s*url:\s*'stage-player-stat'\s*},\s*defaultParams:\s*{\s*(.*?),.*},//s;t' <<< "data:{
url: 'stage-player-stat'
},
defaultParams: {
stageId: 9155,
teamId: 32,
playerId: -1,
field: 2
},"