using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"6[5-9]|[78]\d|9[0789]|1[01]\d|12[012]";
string input = @"1234567
12345C
3456789
345CY
9865432
bA432
6566676869707172737475767778798081828384858687888990
ABCDEFGHIJKLMNOPQRSTUVWXYZ
6711110010100071111108102
Code000Golf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}