$re = '/@\w+|[a-z_A-Z]+(?=\=)|(?<=\=)\w+(?# =后面的变量或者数字)|(?<=\=)\'.+\'|(?<=\=)\".+\"(?# =后面的字符串)|(?<=\=)\[\S+\](?#数组)/m';
$str = '@asd aasdbadkjoiAJF=1123 b=abcABC_ANV c=\'abc_ABC ABC123\' d="abc_ABC ABC123"
@bg a=[1,20,30,40] e=[x,y,z,w] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);