package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(x+x+)+y`)
var str = `
xxxxxxxxxxxxxxxx
Catastrophic backtracking example:
Note the pattern looks fairly simple, but it needs over 80000 steps to decide it is not a match.
With just 16 'x' it already takes a large amount of steps to finally decides it does not work.
(click "regex debugger" on the left to see details on steps taken)
See https://www.regular-expressions.info/catastrophic.html for more info.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}