import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(x+x+)+y";
final String string = "\n"
+ "xxxxxxxxxxxxxxxx\n\n"
+ "Catastrophic backtracking example:\n\n"
+ "Note the pattern looks fairly simple, but it needs over 80000 steps to decide it is not a match.\n"
+ "With just 16 'x' it already takes a large amount of steps to finally decides it does not work.\n\n"
+ "(click \"regex debugger\" on the left to see details on steps taken)\n\n"
+ "See https://www.regular-expressions.info/catastrophic.html for more info.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}