import re
regex = re.compile(r"(x+x+)+y", flags=re.MULTILINE)
test_str = ("\n"
"xxxxxxxxxxxxxxxx\n\n"
"Catastrophic backtracking example:\n\n"
"Note the pattern looks fairly simple, but it needs over 80000 steps to decide it is not a match.\n"
"With just 16 'x' it already takes a large amount of steps to finally decides it does not work.\n\n"
"(click \"regex debugger\" on the left to see details on steps taken)\n\n"
"See https://www.regular-expressions.info/catastrophic.html for more info.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")