#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([0-9a-f]{4}[\.][0-9a-f]{4}[\.][0-9a-f]{4})"
Local $sString = " 42 0050.348a.7a93 dynamic ~~~ F F Po3" & @CRLF & _
"* 82 3550.b5e7.0124 dynamic ~~~ F F Po1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")