using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9a-f]{4}[\.][0-9a-f]{4}[\.][0-9a-f]{4})";
string input = @" 42 0050.348a.7a93 dynamic ~~~ F F Po3
* 82 3550.b5e7.0124 dynamic ~~~ F F Po1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}