using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[id(\d*)\|([а-яА-Яa-zA-ZЁёЙй]*)\]";
string input = @"Пока телефон недоступен для брони, бронируйте в комментариях (мы свяжемся, гарантируем!) или пишите одной из двух очаровательных девушек — [id1554935|Полине] и [id811817|Наташе]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}